feat(revision): update requirements.txt for Odoo 17.0 and 18.0 compatibility
- Add conditional constraints for wheel and setuptools based on Python version - Remove python-ldap and rl-renderPM dependencies for Python <= 3.8 - Reorganize comments to distinguish between Odoo 17.0 and 18.0 requirements
This commit is contained in:
1 file changed
+3
-5
+3
-5
@@ -9,9 +9,11 @@ pylint-odoo
|
||||
pytest-odoo
|
||||
|
||||
# Setup
|
||||
# Until Odoo 17.0:
|
||||
wheel<0.40 ; python_version <= '3.11'
|
||||
setuptools<82 ; python_version <= '3.11'
|
||||
# From Odoo 18.0:
|
||||
wheel ; python_version >= '3.12'
|
||||
setuptools<82 ; python_version <= '3.11'
|
||||
setuptools ; python_version >= '3.12'
|
||||
watchdog
|
||||
pdfminer.six
|
||||
@@ -38,10 +40,6 @@ git+https://github.com/OCA/oca-port
|
||||
git+https://github.com/OCA/odoo-module-migrator
|
||||
git+https://github.com/OCA/maintainer-tools
|
||||
|
||||
# Odoo Compatibility
|
||||
python-ldap ; python_version <= '3.8'
|
||||
rl-renderPM ; python_version <= '3.8'
|
||||
|
||||
# Jupyter Notebook
|
||||
jupyter
|
||||
papermill
|
||||
Reference in new issue
Block a user